Ad Platform segment refreshes have fully recovered and are operating as expected. We apologize for any inconvenience this may have caused.
Posted May 06, 2026 - 15:59 UTC
Update
The system is continuing to run as expected. We will continue monitoring another hour to ensure stability.
Posted May 06, 2026 - 15:32 UTC
Monitoring
We have identified the cause and implemented a fix. We are actively monitoring system recovery as segments are refreshed. We expect full recovery within the next hour.
Posted May 06, 2026 - 14:40 UTC
Identified
We have identified the source of the issue affecting Ad Platform segment refreshes. While we have not yet determined the underlying cause, our engineering team is actively investigating. We will provide a status update within the next hour.
Posted May 06, 2026 - 14:07 UTC
Investigating
We have identified an issue causing Ad Platform segments to not refresh as expected. As a result, affected segments may display stale or incomplete data. We are currently investigating the root cause and the time of origin. Our engineering team is actively working to resolve this issue. We will provide a status update within the next hour.
Posted May 06, 2026 - 13:30 UTC
This incident affected: Advertising Marketplaces (The Trade Desk, Xandr Curate).