Trade Desk Segments not populating

Incident Report for AccuWeather Marketplace

Resolved

Systems continued to run without issue overnight. Segments are populated and are updating regularly again.
Posted Jul 09, 2025 - 13:34 UTC

Monitoring

A fix has been implemented by the TTD team. We are currently rerunning our process and monitoring the fix. Segments will begin populating again at this time.
Posted Jul 08, 2025 - 20:46 UTC

Update

The issue has been escalated by TTD. We will post updates as they become available.
Posted Jul 07, 2025 - 20:06 UTC

Update

We are continuing to work with TTD to find the cause of this outage.
Posted Jul 07, 2025 - 17:29 UTC

Investigating

We experiencing an issue with The Trade Desk API related to updating our segments. Segments are are stale. We are currently working with The Trade Desk to identify the issue.
Posted Jul 07, 2025 - 13:42 UTC
This incident affected: Advertising Marketplaces (The Trade Desk).